Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Arcgis can give such a headache! I want to automate loads of small tasks, and so I need to edit empty TIN with python in order to create a full TIN. My srcript is giving errors, so I tried by hand to make it work with ModelBuilder AND EditTIN IT WORKS FINE!!!!

Exported the same Model (that just worked) as python script gives errors!

# Local variables...
raster = "F:\\...\\mClip_1"
raster_InterpolateShape = "F:\\...\\mClip_1_InterpolateShape"
# Process: Edit TIN...
gp.EditTin_3d(raster, "raster_InterpolateShape Shape <None> softline true")

and the error message:

    Traceback (most recent call last):
  File "F:\....\test_editTin.py", line 26, in <module>
    gp.EditTin_3d(raster, "raster_InterpolateShape Shape <None> softline true")
ExecuteError: Failed to execute. Parameters are not valid.
ERROR 000800: The value is not a member of <None>.
ERROR 000800: The value is not a member of %s.
ERROR 000800: The value is not a member of %s.
ERROR 000800: The value is not a member of %s.
Failed to execute (EditTin).

All extensions and everything is checked since it is exported from model builder. I suppose something wrong is just with first shp input

In ArcgisHelp ex for the input 3d shp name it shows the name with extension

..."masspntz.shp Shape <None> masspoints true"

And so I tried both, with extension and without, but the same errors come.

Any ideas, how can I get that TIN from feature automatically.. ???

share|improve this question
1  
Post your script if you can. –  Roy Sep 19 '12 at 11:14
    
The script or process of the script is clear from the error message, as the rest is just variable definition, tool adding and so on... Well, can post variable if that would change smth :/ –  najuste Sep 19 '12 at 11:42
    
If you can give us the full script it will help with debugging. It is probably a small syntax error, but without the full code its hard to say what it is. –  sgrieve Sep 19 '12 at 12:11
    
indeed it's just syntax. I've found that Arcgis requires here in a script a FULL PATH, so the problem can be solved simply adding variable and joining with the rest to be string.. : gp.EditTin_3d(raster, raster_InterpolateShape+" Shape <None> softline true") –  najuste Sep 19 '12 at 12:13
add comment

1 Answer

Problem of the exporting was that I used local variables.. (Drag and drop from the same environment). And the problem of my script was that following the ArcgisHELP I also used local variables..

For scripting, when EDIT TIN, the full path with data source must be added, so insted just using variable, or local parameters:

gp.EditTin_3d(raster, "raster_InterpolateShape Shape <None> softline true")

should go (variable plus string and then also sapce is important):

gp.EditTin_3d(raster, raster_InterpolateShape+" Shape <None> softline true")

Hr... so simple..

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.