Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to export vector features (current view) as a grid, something like:

so far layer features are not being retrieved.. I got empty grid in the window. would anyone take a look and let me know if I miss something ?

gridPanel = new Ext.grid.GridPanel({ 
        title: "Feature Grid", 
        store: new{ 
        fields: [ 
            {name: "id", type: "int"}, 
            {name: "name", type: "string"} 
            proxy: new{ 
            protocol: new OpenLayers.Protocol.WFS({ 
                url: "http://IP/geoserver/wfs", 
                featureType: "myLayer", 
                featureNS: "", 
                srsName: "EPSG:3857", 
                version: "1.1.0" 
                autoLoad: true 
                sm: new GeoExt.selection.FeatureModel(), 
        width: 320, 
    columns: [ 
        {header: "id", dataIndex: "id"}, 
        {header: "name", dataIndex: "name"} 

        //window to display grid 
        var gridWindow = new Ext.Window({ 
              items: [ 
share|improve this question

Do you receive answer from geoserver? You should see something in firebug. I am almost sure that you have wrong value in featureNS. Check this: How to add GeoServer wfs layer on OpenLayers?

share|improve this answer
I used that exact protocol to add wfs layer to my map so I am sure it's right. but now I need to export features from same wfs layer to grid but got nothing ! – Shadin Sep 20 '12 at 10:52
Maybe for displaying it is OK, but I am no sure if describes your data for Do it, as it is decribed in link given. Set the namespace in geoserver and then change featureNS in your code. – Odoakr Sep 20 '12 at 13:39
I sat my namespace URL in geoserver to so it supposes to work here right ? what's the point of setting it to another URL ? – Shadin Sep 21 '12 at 8:37

What I can see so far is that you have a typo:

you have written

 proxy: new

but correct is:

proxy: new


Just fiddled together a working example:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.