Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I just installed Geonetwork and have been playing around with it on our server (localhost:8080), now I want to access this from other machines on the network but when I type in the address I get a page not found error.

I found this link through googling and altered the jetty.xml file (I couldn't find a mapServices.xml file). As a result I can now get to the page but none of the mapping components work (they all still refer to geoserver on localhost). Is there a location where I can make this change once, instead of going through heaps of file and individual changes?

Thanks Andrew

share|improve this question
    
Opted for a different route. I already had tomcat on this machine so downloaded the war file and installed geonetwork this way. Now working on interfacing it with Postgres. –  Ando Nov 12 '10 at 5:00
1  
Just for other peoples reference I found this article helpful geonetwork-opensource.org/_static/foss4g2010/… –  Ando Nov 12 '10 at 5:30
2  
You can also answer your own questions so people can upvote your answer. –  underdark Nov 13 '10 at 12:22
add comment

2 Answers

up vote 3 down vote accepted

Actually, the link you found through googling is a bit misleading. I was having this same problem after i installed it. What i did was to replace the "localhost" withing the jetty.xml file with "0.0.0.0". This host parameter does not mean what IP to allow through, it means it will listen on that particular interface IP. So it's not "your IP" really, it's the IP of the interface on your server that will be responding to the request. "0.0.0.0" means respond on all interfaces. Hope this helps.

share|improve this answer
1  
Sorry it took so long to respond to this. Second time around with GeoNetwork and its traveling much better, the above solution helped out alot. Thanks! –  Ando May 13 '11 at 0:31
1  
No problem, i added a comment to the thread you found googleing on Feb 23rd as well so people can understand this better if they find that link. –  CaptDragon May 13 '11 at 13:46
add comment

If you do not have a URL assign to it, then you need to find out the IP address of the Geonetwork machine and enter http://geonetwork_ip_address:8080 on the remote machine.

share|improve this answer
    
Simple and brilliant :-> –  GeorgeC Jul 18 '12 at 0:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.