Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I don't know how many of you are using Attribute Assistant for ArcGIS 10.1, hope many:) I have some difficulties with a couple of methods.

Well, I got the INTERSECTING_EDGE, the GENERATE_ID, and a couple of other simple ones right, but I still can't make it work for other ones. For example, several methods give me the approximately same error:

*Field is not specified, empty, or set for all. Trying: CREATE_LINKED_RECORD ERROR: ID or Field to Copy was not found



  • INTERSECTING_FEATURE: Source Layer not found.

  • CASCADE_ATTRIBUTE: ERROR Target layer was not found*

Not sure why "they cannot be found". I hope I wrote the syntax correct. I can imagine it would be difficult to find the problem for each one of them, but is it somewhere a section on ESRI help resources dedicated to the errors in Attribute Assistant log file, and especially how can I fix them? Say on a "Field to Copy not found" error what should I do.

So, if anyone is willing to further help me with debugging this I would be grateful.

I tried this on two computers:

  • 1) arcgis 10.0 + attribute assistant addIn for 10.0.

    • 2) arcgis 10.1 + attribute assistant addIn for 10.1
share|improve this question
More information/background here:… – Rayner Oct 4 '12 at 7:40
that's me, with the same question. :) – Ligia Oct 4 '12 at 11:28

In my experience with the Attribute Assistant, I found that you need to enter the actual field name not the alias in the FIELDNAME field of the DynamicValue table (e.g. ADDPTKEY instead of Address Point ID).

Also, layer names in the TABLENAME field in the DynamicValue table should be the name of the feature class not what the layer is named in the table of contents (e.g. sde.DBO.Parcels instead of Parcels).

It helped me to look at each field in the fields tab of the layer properties dialog, and each layer name in the source tab.

I documented my process in a blog post here.

share|improve this answer

Attribute Assistant is an absolutely marvelous instrument, too bad it doesn't work. My conclusion would be this: ESRI has way too little info on the methods used in Attribute Assistant so you could be doing anything wrong without even know it. I tend to think that the "layer not found" error appears when you don't make the right selection in a FC/ table.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.