Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

For years I have put up with the 2 decimal places that ArcGIS adds to the "currency" formatting, but most of the time I do not want them and end up removing them in my exported map images. I cannot see a way to edit the number of decimals - does anyone have any ideas how to get rid of these decimals?

share|improve this question
    
Are you talking about in labels? And what version of ArcGIS? –  Chad Cooper Oct 1 '12 at 18:28
1  
What file type are you working with. More detail will help. –  Craig Oct 1 '12 at 18:39
    
Chad - yes, the formatting of labels. I am using v10.0 with SP3. @Craig - I'm working with a column in a shapefile called "cost" that is formatted as a long integer. –  Charles Oct 1 '12 at 19:04
    
What about adding thousands separators then after the dollar sign has been added to the string? –  Alex Jun 27 at 14:58

2 Answers 2

You could use Brad's answer in conjunction with a label expression that adds the dollar sign (or other appropriate currency symbol).

VBScript example:

"$" & [CHA_CHING]
share|improve this answer
    
+1 it seems like all you're after is the dollar sign -- a Label Expression is the way to go. –  Roy Oct 1 '12 at 20:17
    
That worked great, thanks. –  Charles Oct 1 '12 at 20:17

EDIT: There may be some business reason you need to have the field set to currency but I think I would manage it in a different way.
Anyway you can also always round the result before displaying the label.
label display

Since it say localized currency settings you might try looking at the windows settings for your computer.
Currency setting

To change the way your computer displays currency values, click the Currency tab. Items you might want to change based on the format language you choose include the currency symbol, the formats used for positive or negative amounts, and the punctuation used to separate numbers.

OLD: If you open the attribute table.
Go to the field you want to modify.
Right click and select properties.
on the properties it should say numeric... Select the ... In that format dialog you will see the number of decimals.
Turn it to 0
Decimals

share|improve this answer
    
Thanks Brad. I'm familiar with editing the number of decimal places for "numeric", but what if you select "currency" instead? There is no way to remove the 2 decimal places for currency. –  Charles Oct 1 '12 at 19:02
    
Thanks for the help Brad. I think adding a dollar sign to your original idea is the way to go. –  Charles Oct 1 '12 at 20:18
    
I notice my image is a bit smallish. Round ([mymoneyfield],0) zero being the number of chars to the right of the decimal –  Brad Nesom Oct 2 '12 at 0:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.