Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am unable to create custom CRSes in QGIS. The 'save' button doesn't seem to have any effect. My best guess is that I don't have permission to save in the folder or database where custom CRSes go. I have looked at the screenshots of other users who are having trouble with this, and I usually see "1 of 1" in the custom CRS browser. On my system, I see "* of 0" instead

enter image description here

Any assistance appreciated.

QGIS version: 1.8.0

Ubuntu 12.04 LTS

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I was able to solve this problem on my own. After some investigation, I found that the ~/.qgis folder was owned by root and had permissions 644. With these permissions, the qgis.db cannot be created when QGIS runs, and settings cannot be saved. There are two ways to fix this problem.

  1. Delete the ~/.qgis folder. It will automatically be recreated when you run QGIS, but with you as owner and permissions 776.

  2. Manually modify the ~/.qgis folder using the chown, chgrp, and chmod commands so that you are the owner and permissions are 776.

Based on issue ticket #914, this problem has been fixed in the source: http://trac.osgeo.org/osgeo/ticket/914

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.