Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am using PostGIS 2.0 and I want to use the raster functionality through mapserver. It seems as if the latest official GDAL release 1.9.1 has an unstable PostGIS raster driver, as pointed out in a previous question. After posting a ticket, was advised on github to update GDAL from trunk for this to work. I did that but I still get the same error. Thus, my question is:

Is it necessary to build PostGIS again from source after updating GDAL for that update to become effective in PostGIS?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

During configuration PostGIS is looking for GDAL, the GDAL-config-file that is: http://postgis.net/docs/postgis_installation.html#installation_configuration

So yes, I think you need to build PostGIS again; I don't know about a way to point PostGIS to a different/new version of GDAL.

share|improve this answer
    
That's true, I did use that flag for pointing PostGIS to my previous local GDAL install. But since my new GDAL trunk installation is at the same place (replacing the previous one), I wondered if it might not be necessary to build PosgGIS again... –  yellowcap Oct 4 '12 at 10:59
    
Yes. Rebuild PostGIS again as that is always the safest option. If you're running GDAL trunk, things should work. It works far better for my projects than 1.9.x –  dustymugs Oct 4 '12 at 15:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.