Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I installed ArcGIS 10.0 and it installed Python 2.6.5 with it. Later, I installed pyGDAL using the windows installer within that Python installation. I cannot find a specific place where GDAL is installed. Is there a way to add FileGDB support to the GDAL libraries that are being referenced by my PyGDAL installation?

share|improve this question
    
Is this where you obtained PyGDAL -trac.osgeo.org/gdal/wiki/GdalOgrInPython ? I've not used it but may check it out sometime. –  PolyGeo Oct 4 '12 at 22:48
    
yes. I downloaded it from there, but I didn't install GDAL itself beforehand. –  Brian Oct 4 '12 at 22:50
    
Mmm. If you have ArcGIS installed, the ArcGIS ArcObjects driver may work better for you since you already have a license for that. gdal.org/ogr/drv_ao.html (it won't act up with weird projections which is the case for the FileGDB driver). –  Ragi Yaser Burhum Oct 5 '12 at 1:04

1 Answer 1

up vote 1 down vote accepted

GDAL itself will be installed on Windows under C:\Program Files\GDAL. However, the python bindings will be installed under the relevant python directory that is recorded in your registry. If you have separately installed Python before or after installing ArcGIS then you will have at least two python versions. This isn't a problem necessarily except, when you install new modules and want to use them in ArcGIS you need to make sure they are installed in ESRI's python locations.

In python, add-ons are located here: C:\PythonXX\Lib\site-packages

Where 'XX' is your version of python without a dot (32 for v3.2 in my case)

If you look in this folder you should find a few gdal .py files but also look for a folder of additional material. In my case it is called osgeo.

However, file-based Geodatabase support is already included as part of the standard GDAL install for GDAL v1.9 so you shouldn't need a plugin. However, there is a plugin for v1.8 (see this post).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.