Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

When I right click on a layer, then click on 'Properties' I would expect the Properties dialog box to appear so I can change the style, add labels etc. For some reason the box doesn't show. It seems like the box is active but not visible - I say this because I can't click on anything else within QGIS until I press escape. Many thanks for the help.

share|improve this question
    
on windows, linux or mac? –  Mapperz Oct 5 '12 at 16:32
    
@Mapperz - on Windows –  QGISnewbie Oct 5 '12 at 16:34

3 Answers 3

See Missing tools (icons) QGIS

Alex Markov: Toolbars are located outside your screen area. You can use Python console to move them on screen. Here is example of moving Navigation Toolbar: qgis.utils.iface.mapNavToolToolBar().move(10,10) Names of other toolbars can be found by this link.

Nathan W: *delete the registry key HKEY_CURRENT_USER\Software\QuantumGIS\QGIS\UI*

share|improve this answer
    
I'm quite new to this system. I did try to move the Layer Properties toolbox back onto the screen using the Python console and the following: >qgis.utils.iface.showLayerProperties(QgsMapLayer*l).move(10,10) But, this error was returned: Traceback (most recent call last): File "<input>", line 1, in <module> NameError: name 'l' is not defined I'm not entirely sure what I'm doing wrong, so would appreciate more help. Thank you. –  QGISnewbie Oct 5 '12 at 17:27

I have had this problem before. I didn't properly seek an answer at the time as I thought it was my computer or me having pressed something unwittingly. The way I found to resolve this was re-installation of qgis. Everything was 'back as it started'/ 'factory settings' as it were... So quite possible there is an option to check/uncheck somewhere. Good Luck!!

share|improve this answer
    
Uninstalling unnecessary –  Nathan W May 7 '13 at 12:44

To reset this (specific) dialog, open a python console and enter the following:

from PyQt4.QtCore import QSettings
QSettings().remove( "/Windows/VectorLayerProperties/geometry" )
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.