Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

There are a few geoprocesses on a recently restored ArcGIS Server that are behaving strangely. If we turn on 'show messages' and try to run the process from the rest interface, the process will report 'failed due to crash or termination of the server object'. This happens at different points in the script and sometimes it will even return messages after the job has officially failed. Every now and then, the final message is 'the job has succeeded' even though the 'Job status' field has been set to 'failed' half way through.

Some information about the setup: Data and server directories are accessed via UNC path Authentication is handled via domain accounts Geoprocesses are backed by Python scripts

I've been searching around for file access issues in both the data store and server output directories. Any advice on best practices to narrow down what may be going on?

share|improve this question
1  
Have you got more than one environment to test on? i.e. Can you replicate in a different environment? –  Simon Oct 13 '12 at 0:25
add comment

1 Answer 1

up vote 1 down vote accepted

The answer ended up being a combination of two things. One, I increased the httpRuntimemaxRequestLength in the 'services' folder web.config to 20000 based on advice in this FAQ. Also, I created another jobs folder adjacent to the original jobs directory, using the same settings but under a different name and virtual directory. Maybe there's something that the post-install sets automatically on the original arcgisjobs folder that I have been overlooking, but these two fixes in tandem did the trick!

share|improve this answer
    
Thanks for letting us know how you resolved it. –  Simon Oct 18 '12 at 10:54
    
No problem, thanks for checking up –  Ryan Twilley Oct 19 '12 at 14:56
    
So, while setting up a second server (using the same data store), I found another detail that I took for granted on the first server. I'm not sure of the exactly why this works, but I could not get gp tasks to complete consistently until I created another jobs directory separate from the jobs directory used for the first server. Another thing to look out for is the SOC account temp folder. It's a good idea to move it to a folder at the root level of a local drive instead of the windows default. ESRI recommends that job paths not be longer than 100 characters. –  Ryan Twilley Oct 19 '12 at 20:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.