Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My friend and I have created a walking network. We created a network without a hierarchy evaluation and the routing worked fine, but when we added a hierarchy to the equation many routes won't solve. We created a hierarchy class and attributed each of our walk types with a hierarchy of 1, 2, or 3. We thought that the cause of the routes not working was when a route would jump from a hierarchy of 3 to 1, or 1 to 3, skipping 2. But routes do work in some of those situations.

Does anyone know why it breaks, or if there is a way to fix it? (We know that all of our paths are snapped together)

share|improve this question
Did you ever happen to find a solution to the problem. I'm experiencing the very same thing. – user3368 Jun 16 '11 at 18:35

hierarchy network analysis ArcGIS should not be breaking

check attribution is correct Network attributes have five basic properties: name, usage type, units, data type, and use by default

share|improve this answer
I believe our attribution is correct, we have a Hierarchy field in the feature class that the network is drawing from, we set the data type to field and the source to that field. The field is in integer format, with values of 1 2 or 3, depending on how we classed the walk type. From reading the ESRI help, it would appear that once on a Primary "road", the route would not go back to a path of a lower class. However, this has worked correctly for us quite a number of times. – Tanner Nov 18 '10 at 21:23
For example, we ran a route analysis with a hierarchy and one without. The result returned two routes, and the one with the hierarchy obviously was searching out paths with a higher value. However, the route traveled along paths with alternating hierarchy values from a primary to secondary back to a primary and to a "local". This worked fine, yet then when trying it again in a different area, it returns an error saying there are no routes. – Tanner Nov 18 '10 at 21:24
what version of arcgis are you running? – Mapperz Nov 18 '10 at 22:06
We're using version 9.3, but we can use version 10 if we need to. – Tanner Nov 19 '10 at 0:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.