Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm running ArcGIS Server 10.1 on a Windows box on Amazon, via remote desktop.

I've set up some services on which I have enabled caching using the Bing/Google/Esri scheme. I explicitly set these to Update Cache Manually.

enter image description here

For some reason, ArcGIS Server is changing these services to Update Cache Automatically. If I change it back to Manual, then immediately re-open the dialog, it has reverted to Automatic. If I choose View Cache Status, it's shown as "Tile Generation is in progress". Cancelling the tile generation has no effect - it immediately restarts.

I am creating these services by first creating *.sd files, in which I specify the cache levels and that I wish for Manual cache generation, then creating ArcGIS Server services from the *.sd files.

Why are these services changing irrevocably to Automatic cache updating?

Thanks

share|improve this question
    
Is sp1 installed ? –  Sunil Jul 11 '13 at 6:18

2 Answers 2

I know this question has been asked some time ago, but just wanted to share what ESRI said about this if others run into this issue. The "Automatic cache updating" radio button or honored when you are going through the publishing or re-publishing process. If you don't want the server to cache your service automatically, just make sure the setting is set to manual each time you go through the publish process.

share|improve this answer
    
hmmm sounds awfully like a bug to me ;) FWIW I've since moved to ArcGIS Online so I'm not seeing this any more, and I can't verify whether it's been resolved –  Stephen Lead Jan 18 at 3:58

Deleting Status.gdb in \arcgisserver\arcgiscache\\Layers did the trick.

share|improve this answer

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.