Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Hello, I tried to use SAGA (Ordinary Kriging) via SEXTANTE in QGis. The Sextante log tells me the following problem. Does anyone have a solution for my problem? By the way I'm usually a SAGA user but I wanted to change to QGis.

Grid: [not set] Variance: [not set] Points: MOORHOF_LUFTENBERG_HERBST_Nuptake_Fert120 Attribute: NUPTAKE Create Variance Grid: yes Target Grid: user defined Variogram Model: Spherical Model Block Kriging: yes Block Size: 100.000000 Logarithmic Transformation: yes Nugget: 0.000000 Sill: 10.000000 Range: 100.000000 Linear Regression: 1.000000 Exponential Regression: 0.100000 Power Function - A: 1.000000 Power Function - B: 0.500000 Maximum Search Radius (map units): 1000.000000 Min./Max. Number of m_Points: [4.000000] - [20.000000]

error: executing module [Ordinary Kriging]

C:\Programme\Quantum GIS Lisboa>saga_cmd io_gdal 1 -GRIDS "C:\Dokumente und Einstellungen\user\sextante\tempdata\test.tif.sgrd" -FORMAT 1 -TYPE 0 -FILE "C:\Dokumente und Einstellungen\user\sextante\tempdata\test.tif"


## #####

### ##

# ## ## #### #

##### ## #

# ## ##### #

library path: D:\Programme\SAGA_Beta\saga_208\modules library name: io_gdal module name : GDAL: Export Raster author : O.Conrad (c) 2007


go...

Load grid: C:\Dokumente und Einstellungen\user\sextante\tempdata\test.tif.sgrd...

failed

error: Grid file could not be opened.

share|improve this question
1  
have you tested it with a path that does not contain spaces (the one you provided contains spaces)? –  SS_Rebelious Oct 17 '12 at 17:06
    
Yes I did. But when I start the Q-Gis program, an error messege pops up "Could not find the Python bindings for SAGA, which are required to run the this plugin.". Is this maybe a cause? –  Pimpel Oct 18 '12 at 8:20
    
I have reinstalled the QGis application. I tried another SAGA-module "Clip points with polygons" but it doesnt work. This is the sextante error log: –  Pimpel Oct 18 '12 at 10:38
    
SAGA execution console output ... ERROR 1: Can't load requested DLL: C:\PROGRA~1\Quantum GIS Lisboa\bin\gdalplugins\1.9\gdal_ECW_JP2ECW.dll 126: Das angegebene Modul wurde nicht gefunden. ERROR 1: Can't load requested DLL: C:\PROGRA~1\Quantum GIS Lisboa\bin\gdalplugins\1.9\gdal_ECW_JP2ECW.dll 126: Das angegebene Modul wurde nicht gefunden. ERROR 1: Can't load requested DLL: C:\PROGRA~1\Quantum GIS Lisboa\bin\gdalplugins\1.9\gdal_MG4Lidar.dll 126: Das angegebene Modul wurde nicht gefunden. ... –  Pimpel Oct 18 '12 at 10:41
    
I have same problem. ERROR 1: Can't load requested DLL: C:\OSGEO4~1\bin\gdalplugins\gdal_ECW_JP2ECW.d ll –  user31023 Jun 4 at 20:06

2 Answers 2

Seems that you need to install Python bindings for SAGA. See information here and more specific for Windows - here.

share|improve this answer

Have you specified the path to your SAGA folder in Sextante options and configuration? What OS are you using? How did you install QGIS? Did you use the osgeo4w installer?

As an aside, I must say that ECW_JP2ECW.dll turns up regularly as a problem in QGIS....

share|improve this answer
    
Yes i have checked the path. I'm using Windows xp. I have installed the program via the common install (*.exe) file. –  Pimpel Nov 6 '12 at 14:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.