Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am having problems with the zoom in QGIS 1.8.0 where a slight move of the scroll wheel on the mouse zooms way way out. It will re-render at each zoom level and with large datasets it takes over the computer for sometimes up to a minute. Is there a way to disable the mouse wheel zoom in QGIS?

share|improve this question
    
I hope somebody can answer this. It's even worse on laptops with scrolling trackpads. –  L_Holcombe Oct 19 '12 at 19:34
add comment

1 Answer

up vote 7 down vote accepted

In the preferences under 'Panning and Zooming' there is a dropdown labeled 'Mouse Wheel Action'

Set this to 'Nothing' and all will be well.

enter image description here

share|improve this answer
    
Thanks, that fixed the problem. –  CDavis Oct 23 '12 at 17:40
    
You might also want to look at the options on the identify function as changing them from the default 'selected' is more like Arcmap –  Stevetech Nov 3 '12 at 10:25
    
Also found that setting Mouse Wheel Action as 'Zoom to mouse cursor' and setting Zoom factor to 1.1 is a reasonable work-a-round. Then a light tap on the magic mouse if zooming in too fast will stop the zoom in its tracks. –  Dion Mar 16 at 8:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.