Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Thanks to iant, dariapra, RK, & rangvald, as the combination of setting up the Geoserver Proxy in the interface, and making changes to the Apache & Tomcat worked. I can now click on the Open Layers and a new window pops up with a blank image within the map surrounding box, all within out IP Address.

So, Solving one issue raised another.

I now need more assitance to fix the new pop up window (after I click the OpenLayers from the Layer Preview pane) in order to show the map that is to be displayed. Within the window, there is the bounding box, text in the bottom left hand corner "Click on the map to get feature info" as well as the bottom righ hand corner "location", and in the IE window, the bottom left identifies a yield sign with paper behind it saying "errors occured".

Is there a way to set this up so the map shows wihtin the new pane after clicking the OpenLayers?

Again, thank you to those who have assited me.

My initial question was: How do I configure Geoserver to show my shapefiles/maps on my Webserver(a specific location as http://www.name.net/geoserver) at work, and not on the localhost:8080? The web server is running Apache and also tried the Tomcat install. Any help is greatly appreciated.

share|improve this question
7  
Where is Geoserver installed? Is that computer accessible from the internet? What is that computer's operating system? Is your webserver accessible from the internet? –  R.K. Oct 25 '12 at 7:11
    
Geoserver was downloaded as a Windwos Installer from GEoserver.org installed in the default location c:\Program Files\GeoServer 2.2. The Computer is accessible from the internet, running WIndows XP Pro, and the webserver has a static IP. –  Brice Oct 26 '12 at 14:54
    
Suggest you move the follow up question to a new separate question and refer back to this one. Also vote up the relevant answers for this question. Mark the question as answered and credit the most notable/relevant answer with the "check" mark for correct/best answer. This is a rating based system, so people would like to get "credits" back as well as be able to help you with new questions. –  ragnvald Oct 30 '12 at 13:31
    
I had gotten geoserver to work the according iant's way.After a few days to a week of not using it to change a few things on another pc with a different project it seems to to have stopped working, only the tomcat says its started but there seems to be another apache icon near it which does not want to start so now I can't seem to access it via the internet. Anybody have any good ideas why this would be please. –  Ravyn Oct 3 '13 at 12:23
    
This is not an answer to the original question and should be asked as another separate question. –  MappaGnosis Oct 3 '13 at 12:44

4 Answers 4

I wrote up my notes on how to do this on a Linux box (but the process is similar on a windows machine). Specifically you need to have Apache redirect the requests to the tomcat at localhost:8080 - you need to edit a couple of files.

share|improve this answer
    
Looks like the notes site is down. Can you update, or post the contents here? –  BradHards Mar 26 at 7:26

In addition to said by iant, I have managed to make my layers publicly available by going to 'Global Settings' in GeoServer's administration interface and setting the 'Proxy Base URL'.

GeoServer administration, setting proxy base URL

share|improve this answer

substitute your ip address for localhost, enable remote connection, open a port that corresponds to your server config.

share|improve this answer

As long as you do not have anything installed on port 8080 the default instructions for installation on the geoserver pages should be sufficient. Geoserver is relatively non-intrusive.

If you are looking for a full package with PostGIS and other relevant tools OpenGeoSuite might be what you are looking for.

share|improve this answer
    
that will not change the port to 80 as the questioner asked. –  iant Oct 25 '12 at 8:48
1  
Still stands. If Brice uses Windows this is the answer he is looking for. Geoserver install instructions for windows are detailed: docs.geoserver.org/stable/en/user/installation/windows/… "Enter the port that GeoServer will respond on. This affects the location of the GeoServer Web Administration Interface, as well as the endpoints of the GeoServer Web Map Service and Web Feature Service. The default port is 8080, although any valid unused port will work. When finished, click Next." –  ragnvald Oct 25 '12 at 9:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.