Sign up ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have Geoserver 2.1.3 set up for WFS transaction. I am using basic authentification and I have set up the following:

  • A role(ROLE_RMP_WFS)
  • A user(user_rmp) which belongs to the role above
  • Data security where rmp..w is set to the role above and rmp..r is set to *
  • No service security
  • Catalog mode config set to mixed

I can query the layer with WFS just fine.

However, doing a insert post transaction through OpenLayers with the URL _ fails with the following message:

<?xml version="1.0" encoding="UTF-8"?>
<ows:ExceptionReport version="1.0.0"
xsi:schemaLocation="    http://kart10utv:80/geoserver_ekstern/schemas/ows/1.0.0/owsExceptionReport.xsd"
xmlns:xsi=""   xmlns:ows="">
<ows:Exception exceptionCode="InvalidParameterValue">
<ows:ExceptionText>Error performing insert: Cannot access rmp_kartobjekt_flate_v with the current privileges</ows:ExceptionText>

However, the object is inserted just fine running the same query in CURL: curl -vv --header "Content-Type:text/xml" -X POST -d @feature.xml _

The feature.xml is the same as the POST content:

I do not understand why it works using CURL, but not working using a regular browser?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

For Geoserver 2.1.3

By default, no service-level security is set. Two examples are given in the file by default, commented out:



Make Sure they are included for WFS_T

Example Service File with the correct security for anonymous use

Note: Restart Geoserver after the file has been edited.

share|improve this answer
Ok, I set the role ROLE_RMP_WFS to wfs.Transaction and then it worked in my browser as well. But I still do not understand why it worked using CURL without this setting when it did not work in my browser. Thanks a lot! – Espen Oct 29 '12 at 9:23

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.