Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have got a Personal Geodatabase with a feature class and several coded value domains. Domains are assigned to some of the attributes of said feature class. Domains are correctly defined and match the field's attribute types. The attribute values are within the defined domains.

Somehow the coded value descriptions are no longer displayed and instead I can see the 'raw' attribute values. Which, of course, I don't want to see.

How do I tell ArcMap/ArcCatalog to display the domain descriptions instead of attribute values?

share|improve this question

Have you checked that the option in the Appearance dialog of the attribute table view doesn't have the option 'Display coded value domain and subtype descriptions' unchecked? Also, you won't be able to work with the domains if the dataset is open in ArcMap - and it won't tell you that is why. It just won't give you the option.

share|improve this answer
Thanks, but the option to display the domain descriptions is enabled and closing ArcMap doesn't have an effect. – AndOne Nov 25 '10 at 10:18
up vote 1 down vote accepted

The underlying problem was that the feature class in question had a subtype. That subtype was an integer and allowed NULL values. That field also had a coded value domain assigned to it. When there was a NULL in that field then ArcGIS wouldn't display coded value descriptions for any of the other fields in that row.

Assigning the subtype for all features fixed the displaying issues. I don't know why the data model allows NULL values for the subtype in the first place...

share|improve this answer

Have you tried to export your Domains via the Domain to Table tool in ArcToolbox? Then you can import them to your Geodatabase and assign new names to them (via the Table to Domain tool in ArcToolbox), and then try assigning the new domains to your Fields. Maybe then it will work again.

PS. check the resulting tables, before importing them - there may be posts, that you want to change before importing them again.

Good luck :-)

share|improve this answer

The solutions for Copy domain and only domain may help here.

share|improve this answer

Have you tried to right click on the connected feature class and remove the domain connection in either the fields or subtypes tab. Once done you should then be able to convert the Domain to Table (using a GP tool) and then delete it. Lastly reimport the table as a Domain and reassign to the feature class either via subtype or domain.

Hope this helps, CDB

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.