Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I created a KML file from a geotiff using Geoserver, but the image looks really pixelated in Google Earth. The image is a geotiff and is only around 7MB. Any reason why it might look so pixelated?

share|improve this question
    
which version of Geoserver are you using? –  R.K. Oct 31 '12 at 3:47
    
I am using Geoserver version 2.2 –  Derek Hernandez Oct 31 '12 at 13:16

2 Answers 2

Found this on a mailing list and I think it is should address your situation as well:

If you have .tif and .tfw files then you probably do not have geotiff, just a plain tiff with world file for georeferencing. Problem is that world file does not tell the projection. You can try two options:

  • Convert image to GeoTIFF with gdal_translate. Command to use could be like gdal_translate -of GTiff -a_srs epsg:4326 -co tiled=yes test.tiff georeferenced.tif
  • Or create a .prj file which contains the information about the projection in the ESRI style and place it to the same place as .tiff and .tfw

You might want to convert it to a real GeoTIFF as suggested in the list and see if it works.

As for the pixelated images, you can try tweaking the WMS Raster Rendering options.

enter image description here

Try using the bilinear or bicubic interpolation. It should be able to address your pixelation issues.

share|improve this answer

Please do inner tile and add overviews to your tiff file, see here: http://demo.geo-solutions.it/share/foss4g2011/gs_steroids_sgiannec_foss4g2011.pdf

share|improve this answer
    
I added tiling and overviews as you suggested, but the image still appears the same. Any idea what is wrong? –  Derek Hernandez Oct 31 '12 at 13:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.