Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Measurements done in QGIS on my project are done properly using whatever unit is set in:

Settings > Options > Map Tools > Preferred measurements units

but the scale bar decoration and scale bar in print composer are still degrees. My data is all NAD83. Previously answered questions state that it must be changed in project settings but I don't see that menu option in QGIS 1.80.

How can I change settings so that my scale bar is in units other than degrees?

EDIT 1: I don't have that option in the menu (are you using 1.80?), but I do have a button for 'CRS status' on the status bar. If I click that and change layer units to feet, which it indicates are only used when CRS transformation is disable, I get the following:

enter image description here

As you can see, the scale bar measurement is completely off. I can change the CRS to other systems than use feet other meters and it's more accurate. Are there metric and imperial version of NAD83, WGS84, etc?

If the measure tool can give figures in feet or meters when using a CRS with degree units, why can't the scale bar do the same?

share|improve this question
1  
Units disagreements like this are almost always caused by projection disagreements. NAD83 isn't really a projection; I suspect you're using a State Plane coordinate system based on NAD83. If you have any further info about the data source, I can make further suggestions. –  L_Holcombe Oct 31 '12 at 5:49
    
Thanks for your answer. The data is from central Washington state so I played with both the north and south plane projections to see which worked best.Here's some metadata that might be useful: (Layer Spatial Reference System: +proj=longlat +ellps=GRS80 +datum=NAD83 +no_defs) / (CRS = EPSG:4269 - NAD83) I've been setting my project as 'NAD83 / Washington North (ftUS) - EPSG:2285' or 'NAD83 / Washington South (ftUS) - EPSG:2286' The data source is the USGS National Map viewer. –  Veazer Nov 7 '12 at 19:36
    
Just found this great tutorial for dealing with projections. It's for 1.7.4, but it works in 1.8 as well. If you reproject your data to WashN or WashS, and then set your project to the same projection, the units should match up. qgis.spatialthoughts.com/2012/04/… –  L_Holcombe Nov 7 '12 at 21:38
add comment

2 Answers

The Project properties dialog is available through the File->Project Properties or by clicking on button displayed at the bottom left of the QGis main window.

To change the unit to use go to Project properties->General->Canvas units.

share|improve this answer
    
Please see EDIT 1 above. –  Veazer Oct 31 '12 at 4:38
    
Ctrl+Shift+P does the same. The properties menu item was gone from some Linux distributions of QGIS. –  scruss Oct 1 '13 at 12:08
add comment

You have to make sure that the layer CRS is correct. You get that information by rightclick on the layer -> Set CRS for layer. You can also look out for the extent entry in Layer properties, metadata tab. If that is around values suitable for degrees, take NAD83, else the CRS in ftUS or metres.

The project CRS may be different, and has to be if you want other units than the layer originally has.

If you are not sure what is correct, please post sample coordinate pairs of what you got and what it should be.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.