Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

At QGIS startup I get the message: "QGIS couldn't find your GRASS installation. Would you like to specify path (GISBASE) to your GRASS installation?" (Windows 7) No amount of rooting around the directory structure in the GRASS directories solves it. Tried uninstalling/reinstalling, no joy, but I also noticed that my plugins were still there, so the uninstall does not appear to have been fully clean.

I have a perfectly working installation on another Windows 7 machine that I installed just last week, so no clue why there's a problem on this machine.

Ideas?

share|improve this question
1  
Which installer did you use? The standalone or the OSGEO? –  HeyOverThere Oct 31 '12 at 17:18

4 Answers 4

you can create it manually (create the folder) and when you start the grass-plugin just select it as follows in the screenshot by using the browse-button: enter image description here

share|improve this answer
    
Thanks. So the plugin works, but the error message still persists. –  Steve Bernstein Oct 31 '12 at 22:41
    
@Steve Bernstein: sorry to hear, that the message still pops up –  Kurt Nov 1 '12 at 8:23
    
@Steve Bernstein: take a look at: c:\users\username\AppData\Roaming\GRASS6 there should be something like this:GISDBASE: C:\Users\Kurt\Documents\GIS DataBase\China LOCATION_NAME: Austria-Projekt-Location MAPSET: PERMANENT GRASS_GUI: wxpython –  Kurt Nov 11 '12 at 8:11

I had the same problem, using Windows 8.1, and the final and simplest answer ("Uninstall, and reinstall into C:\Program Files\QGISValmiera (without a space between QGIS and Valmiera) and it works.") worked for me. Thank you, Eliptical view.

share|improve this answer

Follow-up. This worked: Uninstalled, cleaned the registry (w/CCleaner), deleted residual folders. Reinstalled with the OSgeo4W Windows installer instead of the QGIS Windows installer, all good.

Oddly, all my plugins are still installed, so it appears despite believing I'd taken every step I know to truly uninstall, there were artifacts of the previous install. IMHO, that oughtn't be.

share|improve this answer
2  
did you also look at c:\users\YourUsername\.qgis here are the plugins stored for the user called YourUsername –  Kurt Nov 3 '12 at 10:53

Uninstall, and reinstall into C:\Program Files\QGISValmiera (without a space between QGIS and Valmiera) and it works.

The windows installer is not putting double quotes around path names which contain special characters like spaces. You can see this in your install log at: C:\Program Files\QGIS Valmiera postinstall.log. I have submitted a bug report.

Solution first came from here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.