Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have ArcGIS 10 installed on my computer connected remotely to my companies license server. Everything has worked fine for months, but within the last few days no geoprocessing tool will run. The results window just shows the dreaded 99998:Unexpected Error. Looking further into the log file I get this:

<Msg time='2012-10-31T22:33:50' type='ERROR' code='5000' target='GPJobServer.GPJobServer' thread='3872'>Job Catalog initialization failed. Directory C:\Program Files (x86)\ArcGIS\Desktop10.0\ArcToolbox\server\system\jobreg\ not found.</Msg>
<Msg time='2012-10-31T22:33:50' type='ERROR' code='1016' target='GPJobServer.GPJobServer' machine='KYLE-PC' thread='3872' elapsed='0.33800'>Server Object instance creation failed on machine KYLE-PC.   Job Catalog initialization failed. Directory C:\Program Files (x86)\ArcGIS\Desktop10.0\ArcToolbox\server\system\jobreg\ not found.  </Msg>
<Msg time='2012-10-31T22:33:50' type='ERROR' code='1008' target='GPJobServer.GPJobServer' thread='8072'>Configuration GPJobServer.GPJobServer can not be started.</Msg>
<Msg time='2012-10-31T22:33:50' type='ERROR' code='1006' target='GPJobServer.GPJobServer' thread='8072'>Configuration GPJobServer.GPJobServer can not be stopped.</Msg>
<Msg time='2012-10-31T22:33:50' type='WARNING' code='1034' target='GPJobServer.GPJobServer' thread='8072'>Warning: Changes to server object configuration GPJobServer.GPJobServer could not be saved to disk and will not be available when SOM restarts.  Reason for failure: Operation on file C:\Program Files (x86)\ArcGIS\Desktop10.0\ArcToolbox\server\user\cfg\GPJobServer.GPJobServer.cfg failed. File not found.</Msg>

Does anyone perchance know what might be going on? Where did the jobreg file go? Do I need to reinstall the software? This all happened completely randomly, and I never touched any of the AppData files, nor the Program Files.

share|improve this question

closed as off-topic by PolyGeo Jul 16 '15 at 7:28

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

Solved. I repaired the install of ArcMap

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.