Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Using QGIS and one minute I could see the attribute table, the next minute I couldn't. Using QGIS on Linux Mint 13. I tried purge/autoclean/reinstall to get a completely new download of all dependencies and no saved config files, but the problem persists. I can't see the attribute tables for either shapefiles or SpatiaLite data (haven't tested PostGIS yet).

Note, the underlying data is there. I can open the DBF in LibreOffice and see the expected data, and if I click on a feature with the Identify Features tool, I do see the attributes associated with that feature. Symbolization of the data (e.g. a simple choropleth map) also works based on the underlying data. The attribute table displays all expected columns, but no rows, as if it was a newly created completely empty layer.

This was a recent install on a new computer, but for the last week I have been able to add data and view attribute tables as expected. Today I set the configuration option to "Open attribute table in a dock window (QGIS restart required)" and then when I tried look at the attribute table, no data was displayed. I restarted QGIS, still the same. I then turned off the docking, no effect, restarted the computer, no effect. Completely reinstalled QGIS as indicated above, no effect.

One obvious gotcha is that "Show selected only" could be checked, but that is not the case here.

Has anyone run into this or know how to fix it?

share|improve this question
    
Clarification: is Show selected only checked or not? If it is, and nothing is selected, there will be nothing shown in the attribute table. –  L_Holcombe Nov 5 '12 at 22:12
    
See the second to last paragraph. It's not that obvious. –  Lee Hachadoorian Nov 5 '12 at 22:47
    
Your second-to-last paragraph was ambiguous, which is why I asked. –  L_Holcombe Nov 5 '12 at 23:32
1  
"Show selected only" is not checked. Edited that part of the question to make that clear. –  Lee Hachadoorian Nov 6 '12 at 2:44
    
To make sure its a bug; Is the same result comes with "toggle editing" mode ON. could you provide a screenshot –  rashad Nov 6 '12 at 17:00
add comment

1 Answer

up vote 1 down vote accepted

Under Settings->Options->General (a bit down the panel) I have a dropdownbox "Behaviour of Attribute table" (or whatever it is in your language).

After switching that to "Show All Objects", I see them in the table. It looks like that overrides the checkbox in the attribute table itself.

share|improve this answer
    
Thanks, André. That is exactly right. I inadvertently changed that setting using the scroll wheel while I was setting the attribute table docking behavior in the same dialog. –  Lee Hachadoorian Nov 6 '12 at 20:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.