Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Possible Duplicate:
Qgis polygonize problem - DLL load fail

[I had already posted this question, but was closed and redirected to a supposedly duplicate question. I'm re-posting since I believe this is note exactly the same case.]

I'm getting the following error message when I try to use the polygonize tool in QGIS 1.8 (windows 7):

Traceback (most recent call last): File "C:\PROGRA~2\Quantum GIS Lisboa\bin\gdal_polygonize.py", line 34, in import gdal, ogr, osr File "C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages\gdal.py", line 2, in from osgeo.gdal import deprecation_warn File "C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages\osgeo__init__.py", line 21, in _gdal = swig_import_helper() File "C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages\osgeo__init__.py", line 17, in swig_import_helper _mod = imp.load_module('_gdal', fp, pathname, description) ImportError: DLL load failed: No se encontró el proceso especificado.

I have already tried or checked the following with no success:

  • Making sure there is no PYTHONPATH variable
  • adding "C:\PROGRA~2\Quantum GIS Lisboa\bin\", "C:\PROGRA~2\Quantum GIS Lisboa\bin" and "C:\PROGRA~2\Quantum GIS Lisboa\" to the beginning of PATH variable
  • Checking that GDAL was not installed separately
  • Installed Visual Basic 2010 Express (couldn't find Visual Studio 2010 as suggested in the other post)
  • "Path to the GDAL executables" and "Path to the GDAL Python modules" are blank in he GDAL setting menu within QGIS.

Any ideas what this could be? I wonder why would it be the path variable if all other Gdal are working fine. Wouldn't it have a DLL load error for all or other Gdal modules?

share|improve this question

marked as duplicate by R.K., whuber Nov 8 '12 at 13:46

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

Installing Qgis in a folder without blanks will solve a lot of problems related to that. The osgeo4w-setup is one option for it.

share|improve this answer
    
I just tried installing QGIS in a folder without blanks --didn't work, I still have the same problem –  Andres Nov 19 '12 at 21:41
    
OK next possibilities: Has your Windows user name non-ASCII characters? Is there another installation of python or gdal on your computer which might interfere? –  AndreJ Nov 20 '12 at 5:10
    
Thank you for keeping up with the help, @Andre, I just checked your suggestions. My Windows user name is plainly "andres", so that cannot be the problem. I only have one version of Python installed (2.7). I do not know how to check the gdal installation (I didn't install it myself; it got installed when I installed the QGIS standalone installer). No other QGIS version is installed either. –  Andres Nov 21 '12 at 5:44
    
With the installation, you got a OSGEoW icon. If you start that, you should get a list of available Gdal tools, and the version info. That should be 1.9.1. Alternatively, you can try the OSgeo4w setup of Qgis, which will install to C:\Osgeo4W, and has its own gdal with it. Maybe that solves your problem. And/or you can install qgis-dev from Osgeo4W setup with gdal 1.9.2. –  AndreJ Nov 21 '12 at 6:54
    
problem solved! Thank you so much. Just one question: On the OSgeo4w icon it says the gdal version is 1.7.3. How can I upgrade it to 1.9.2? –  Andres Nov 22 '12 at 18:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.