Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm trying to use a cross-hatch symbol on polygons in QGIS.

When displayed on screen, they look just fine - both in the map and in the composer.

The problem is when they are rendered to an image and/or printed, the hatching is much smaller in size (between the hatches) than on screen. The result is a much darker looking polygon that simply looks black, rather than a cross-hatch pattern that can be seen through to the colours below.

There is a print resolution setting (DPI) that when changed to 96dpi, it will render as it does on screen. But how to fix for 300dpi printed maps?

Thanks!

share|improve this question
2  
it would also be very beneficial to the community is you could click the "checkmark" next to answers that solved your previous questions and move the questions into a "resolved" status. –  RyanDalton Dec 10 '12 at 16:27
    
Ryan: is this something I'm forgetting to do? –  mapBaker Dec 11 '12 at 17:16
    
Yes, for example, if someone below answered your question, and it was the "best & correct" answer that helped you the most, just click the white "checkbox" next to their answer. It will turn green, and it will then be shown as "resolved". –  RyanDalton Dec 11 '12 at 21:30

2 Answers 2

up vote 2 down vote accepted

You could try the "New symbology" button (top right on the layer properties panel), then the "Change" button (middle left, under the preview) and then two angled "Line pattern fill".

Another solution : SVG Symbols, cf. Is there a SVG symbol library for qgis?

share|improve this answer
    
Laurent: I don't see that option. Could you be more specific? Thank you! –  mapBaker Dec 11 '12 at 17:17
    
Sorry i was translating from my french version, i corrected. –  Laurent Jégou Dec 12 '12 at 11:55
    
Got it! This is actually (in QGIS / Ubuntu) under: - symbol properties - symbol layer type - choose 'line pattern fill' - you then have all the options... Thank you!!! –  mapBaker Dec 19 '12 at 20:47

You can try to define the pattern using 'map units,' which should maintain relative sizes between the pattern and feature. However, even then, the pattern may shift (via x/y) even if proportionally correct.

share|improve this answer
    
dakcarto: I still need to change the spacing of the cross-hatch - an option which I can't seem to find...Thank you!!! –  mapBaker Dec 11 '12 at 17:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.