Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am looking to interpolate a DTM (eventually over 4,000 DTMs) that is in a personal geodatabase format. I would like to do this in as few step as possible, eventually writing a batch script to do them all.

I was under the impression that I could use gdal_grid to accomplish this but I am getting the following error.

ERROR 1: Unable to initialize ODBC connection to DSN for DRIVER=Microsoft Access
Driver (*.mdb);DBQ=17509200.mdb,
[Microsoft][ODBC Driver Manager] Data source name not found and no default drive
r specified
Unable to open input datasource "17509200.mdb".
Unable to initialize ODBC connection to DSN for DRIVER=Microsoft Access Driver (
*.mdb);DBQ=17509200.mdb,
[Microsoft][ODBC Driver Manager] Data source name not found and no default drive
r specified

after using the following command: gdal_grid 17509200.mdb test1.tiff -zfield ELEVATION -ot Float64 -l 17509200

I am using GDAL 1.9.2 on a Windows machine.

My version does support reading of "Pgeo" so I thought gdal would be able to use the mdb as an input, and output a raster. But apparently I have to specify a driver (Im not sure why it cant use PGeo?). I have seen on other forums Linux users using various MDB driver extentions. Does anything exist similar to that for Windows? Or can I specify the PGeo driver in gdal as it is now? How do you specify a driver in gdal?

Any suggestions?

Thanks.

share|improve this question
    
I would use ogrinfo on the mdb alone to check that you can access that correctly –  mdsumner Feb 8 at 20:09
add comment

2 Answers

Try setting the -l option as the name of the layer within the geodatabase. Also try running oginfo on the .mdb file to see if it can read anything.

share|improve this answer
    
Ill give it a shot. Thanks for the suggestion. –  glw Nov 13 '12 at 14:27
    
I get an identical error message as the one above with ogrinfo. –  glw Nov 13 '12 at 14:40
add comment

You need to configure the ogr driver with an odbc driver. See:

http://gdal.org/ogr/drv_pgeo.html

and follow the instructions.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.