Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have a DEM of my study area, and the streams in it. Whenever I add both to ArcScene, and drape the vectors over the DEM, some of the vectors disappear from over the surface, and are visible under the surface. (see Image below). enter image description here

Are there any specific settings to properly drape the vectors over the DEM? Are there any other options or software that produce a better result (visually) when you have to drape vectors over a DEM?

share|improve this question

3 Answers 3

I have made ​​the experience that the problem can not always be solved completely. But if you use layer's drawing priority, it gets better. Please try to use the layer's drawing priority:

In ArcScene you can change the drawing priority of each of the layers being displayed, so the more important layers will render on top of the less important layers. Using the 3D Effects toolbar you can change this property quickly. Steps:

  • On the 3D Effects toolbar, click the Layer drop-down arrow and choose the layer you want to change the draw order for.
  • Click the Change Depth Priority Change Depth Priority button and move the slider to a value.

In the numeric scale for depth priority, 1 is the highest and 10 is the lowest. If you want to decrease priority, choose a higher number.

share|improve this answer

How did you drape the vectors? I think you need to set the Base Heights. To do so:

  • Right click the vector data layer and select Properties.
  • Click the Base Heights tab.
  • Select the radial button beside Obtain heights for layer from surface. The program automatically selects the DEM open in ArcScene.
  • Click Apply, then move to the Extrusion tab.

enter image description here

  • Put a check in the box beside Extrude features in layer and change the extrusion value to 2 or 3. Test different values to see the changes on the map.
  • Click Apply to view the changes or OK to return to the ArcScene map window.

enter image description here

Hopefully, that'll do the trick :)

Another option would be to use the Virtual Terrain project. It's an open source 3D visualization tool.

The goal of VTP is to foster the creation of tools for easily constructing any part of the real world in interactive, 3D digital form.

This goal will require a synergetic convergence of the fields of CAD, GIS, visual simulation, surveying and remote sensing. VTP gathers information and tracks progress in areas such as procedural scene construction, feature extraction, and rendering algorithms. VTP writes and supports a set of software tools, including an interactive runtime environment (VTP Enviro). The tools and their source code are freely shared to help accelerate the adoption and development of the necessary technologies.

enter image description here

They have a nice tutorial page. Good luck :)

share|improve this answer
    
I have tried using the Extrusion; If it is too small, then some features still disappear, and if it is large, then you can see the extrusion, thus making it feel unnatural. –  Devdatta Tengshe Nov 9 '12 at 7:32
    
You've set the Base Heights too? –  R.K. Nov 9 '12 at 7:41

Another option would be to convert the vectors to 3D lines, using the DEM as a base height. This willake the lines "extrude" automatically and will be at the height above the DEM. I have experienced this issue before and it's very frustrating. If you are soley looking for a visual fix, you can apply a floating value to the extrusion and the lines will float above the DEM, not ideal, but will work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.