Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am pretty new to ArcGIS and Qgis. I have loaded some geometry data in Qgis from my postgres database, then I have also loaded the same data in ArcGIS. Then from ArcGIS i have created a shapefile containing part of the data loaded from the database.

Now my problem is that when I load the shapefile containing part of the whole geometry data in Qgis, they are not being displyed on top of each other. Instead they are displayed both totally in different locations.

Now my data from postgres is set to 4326 and my data created in ArcGIS is set to wgs1984 UTM 33N.

I have uploaded these two images to explain more myself. I would like that in qgis will appear that the blu rectangle will be on its twin rectangle. NOT ON ANOTHER PART

enter image description here

share|improve this question
    
Just create the Shapefile in 4326 too. Or is your question how to do exactly that? –  underdark Nov 13 '12 at 14:49
    
but from arcgis it asks for the utm zone location rather then just 4326 like in postgres. it might be that i am doing somehting wrong. And what is exactly the differencxe between 4326 and the UTM ZONE location? –  Ryan Nov 13 '12 at 14:57
    
Please clarify your question. –  Alexandre Neto Nov 13 '12 at 14:58
2  
4326 = WGS 1984 = lat/lon geographical coordinates (degrees). This is NOT the same as UTM. UTM is a projected coordinate system. –  Jens Nov 13 '12 at 15:03
    
do you know how i can edit the projection from qgis?. because if so i think it is a proejction problem. –  Ryan Nov 13 '12 at 15:21
show 1 more comment

2 Answers 2

If you just want the shapefiles to line up then select a project Coordinate Reference System by going to Settings > Project Properties. From Spatialthoughts blog:

Check the box next to ‘Enable ‘on the fly’ CRS transformation’. Next select the ‘common’ projection that all the current and subsequent layers would be automatically reprojected to. We would keep that as WGS84. Click OK.

enter image description here

Right click on either of your layers and click Zoom to Layer Extent. They should line up now.

share|improve this answer
    
I have done that and still the same. I am not sure if this helps to solve the problem but my scale of one layer when i do zoom to layer extent is: 1:12164152 and the other is 1:387. could it be something from this?? –  Ryan Nov 13 '12 at 15:44
    
Open a new ArcMap. Add your shapefile to ArcMap. 1) move the mouse - tell what coordinates are shown in the status line of ArcMap. 2) open the properties of the layer. what coordinate system is shown on the coordinate system tab? –  Jens Nov 13 '12 at 16:12
add comment

In QGIS, go to Layer Properties of the "wrong" layer and change the projection to 4326. If the layers align, it tells us that the Shapefile was wrongly exported from ArcGIS.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.