Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I recently ran the 10.1 sp1 and my scripts stopped working. I can't even right click on the scripts and check properties without the following popping up:

InitializeParameters Syntax Error:  Runtime error
Traceback (most recent call last):  
File “#ANNOBO2.InitializeParameters.py”, line 1, in module
File “d:\arcgis\desktop10.1\arcpy\arcpy\__init__.py”, line24, in module
From arcpy.toolbox import*
File “d:\arcgis\desktop10.1\arcpy\arcpy\toolbox.py”, line 485, in <module>
From management import ExportTileCache as ExporttileCache_management
ImportError:  cannot import name ExportTileCache

I did a little digging and found all the tools in python script in the management.py. What was missing was the scripts for the Tile Cache toolset. Not sure what happened when I installed sp1 but now I just want it fixed.

Any help would be greatly appreciated. Thanks in advance.

Currently using Python 2.7

Ah, ok. Ill look and see if there are any reminants of older python on my system. If not ill try to reinstall everything. Thanks for the quick replies.

share|improve this question

closed as too localized by underdark Nov 16 '12 at 6:37

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Which version of Python are you using? –  Mintx Nov 14 '12 at 19:59
    
I've got 10.1 SP1 installed and I can import arcpy with no errors. It seems like your SP1 install didn't update your arcpy folders, or you're accidentally calling an old Python version. (I get the same errors above when I try to import arcpy in Python v2.4) –  Mintx Nov 14 '12 at 20:39

1 Answer 1

Thank you for your help Mintx. I had 2 versions of python on my computer. I removed both then, jsust to be thorough, I also uninstalled sp1. Then I used to original install disk and re-installed python and ran sp1 again. Everything works fine now. Looks like it was pointing to an older version of python after all. Thanks again.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.