Sign up ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have installed Mapnik-2.0.1rc0 in windows 7 32bit machine. I then tested the installation by import mapnik from * and it did not return any error. But when I tried to input the config version checking by mapnik-config -v, it returns a name error. When I tried to run, the following error occurred:

the mapnik library and python bindings must have been compiled and installed successfully before running this script

This probably happened due to improperly set PATH and PYTHONPATH.

How to add PythonPath?


share|improve this question
shouldn't it be mapnik-config -v instead of manik-config -v; and instead of – user8723 Nov 18 '12 at 4:49
Sorry for that. it will be mapnik-config -v and – Devils Dream Nov 18 '12 at 7:26

1 Answer 1

Explanation exist on Github project Manual instructions for install Mapnik on Windows.

Step 3 is for you ;-)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.