Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have imported a .gpx file into qgis and separated the track waypoints using Vector > GPS > GPS tools. When viewing at full extent I can see the original track and component waypoints. However when I zoom in, the track lines disappear but the waypoints are still there. I have tried:

  • checking track layer scale dependent rendering is OFF
  • exporting track layer as .shp and adding to map
  • moving track layer to top of layer stack
  • toggling map rendering

but still cannot view track when zooming in. Any ideas?


[EDIT] I have uploaded Pic1 which shows zoomed to the layer extent ('GPX tracklog export'). Pic2 is when it has zoomed in with mouse wheel and part of the shapefile has diappeared. Note these are the gpx file tracklog exported as a shapefile.

Pic1 - at image extent

Pic2 - zoom in

share|improve this question
For a shapefile, sometimes the .sbn and .sbx files cause this behavior (which you may delete). – artwork21 Dec 4 '13 at 13:49
I experience the same problem with a vector shapefile sent to me from the British Oceanography Data Centre (so I assume it shouldn't have too many faults? Not necessarily true). Looks fine when zoomed to layer full extent, disappears completely when I zoom in. I'll raise this as a bug @ Please comment if you've had the same experience. – dez93_2000 Jan 22 '14 at 16:54
I have the same problem with data recorded with a garmin gps, whole track disapears when zooming in. – user16032 Aug 20 '14 at 10:14
artwork21 thank you! it worked! – Piotr Sadowski Oct 8 '14 at 6:50
Or a .qix file in my case – Bluefox Apr 15 at 9:12

Does it help to insert points into the way geometry?

Sometimes ways don't get rendered if all points of the way are outside the current window.

[EDIT 2] from user19425 I can't seem to add a separate comment, possibly because this is a closed question. But anyway thanks Joost, that worked. Are you aware if this is a tracked bug?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.