Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Is there a way to export a table with selected records to an Excel spreadsheet? I was trying to export just to .txt file but ArcGIS gives me an error message.

The other problem I have is with coordinates. I want them only with one locus after the comma, I mean like the format: xx xx xx,x not like I have now xx xx xx,xxx.

alt text

Do you know any solutions? The version of my software is 9.3

share|improve this question
add comment

3 Answers

up vote 9 down vote accepted

Do you receive the same error by copy/pasting records?

This is from memory, but if you right-click on the gray row indicator box, your menu should have "Copy Selected Records". Then you can paste directly into an Excel spreadsheet. alt text

A caveat: if your selections are in a related table that are a result of a feature selection, you might actually have incorrect selections (you get rows in your related table that aren't actually related to any of your selected features and you could be missing others). One of my users discovered this issue, which appears intermittent. I did narrow down the issue to ArcMap. The geodatabase+custom ArcObjects test code works correctly. Our workaround: if our users need the related data for something important and the number of records is too large for them to visually inspect, we obtain the data from the database using a sql query. We haven't seen this issue with ArcGIS 10.


Update: You said you got the data into Excel. Are your DMS values in a text field? You might be able to parse the information that you need and round your decimal value. based on what I see in your screen shot, i came up with:

=LEFT(A1,8) & ROUND(VALUE(MID(A1,9,6)),1) & MID(A1,15,2)

alt text

http://dl.dropbox.com/u/1156285/example.xls

share|improve this answer
    
Great! It's working :) What about the second question about coordinates? Now i was trying to set it directly form exel but i don't see any format for coordinates...Any suggestions? –  com Dec 4 '10 at 12:31
1  
I'm not at a workstation, so I don't know of anything from memory. Hopefully, someone else who knows that answer will post it. Your second question should be a second stand-alone question and it's likely a future answer-seeker would find answers to that second question useful. You could probably use your same screen shot. –  Jay Cummins Dec 4 '10 at 12:39
    
It is not working. It gives back #ARG error in spreadsheet. The best would be to do it in Arc, but I;m not sure if it is that possibility? Maybe i should ask another question for this one as Jay said... –  com Dec 4 '10 at 14:22
add comment

the export has a bit of a bug I have found. If you export, then select the browse for the file location, then type in the file name the default "of type" is set to feature class or something. You need to select the type of dbf table. Then you would need to open and saveas in excel to xls.

share|improve this answer
1  
You can set the decimals to display for the field. –  Brad Nesom Dec 4 '10 at 14:30
1  
On a side, note, I moved from QGis to ESRI (yes, I know the opposite way to most people), and there is nothing in the Arc products that doesn't have a bug of some sort. reminds of a continuous product cycle of windows me –  dassouki Dec 4 '10 at 15:01
    
Ad Brad Nesom: I can't because the field is not a numer type (it contains not only numbers) –  com Dec 4 '10 at 16:52
add comment

I thing, the most convenient option is to export the data from attribute table and save it as .txt file (change the extension from .dbf to .txt). After that open this file into excel. That,s it.

share|improve this answer
    
Please explain your answer in detail –  Sunil May 27 '13 at 8:28
    
The Question said "I was trying to export just to .txt file but ArcGIS gives me an error message" so the asker has already tried this. –  PolyGeo May 27 '13 at 8:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.