Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I've got a 10.0 gp service running on Windows Server 2008. The gp service writes to a folder on the server. The parent of this folder is shared.

When it comes time to delete folders on the server, occassionally I find that it is locked by ArcGISCacheMgr.exe.

Does anyone know what this process does, or how I can get it to let go of my folder?

Update: The ArcGISCacheMgr.exe process is running under the ArcSOC user account, so this makes me think it has something to do with ArcGIS server. (The folder is created by the gp service.)

share|improve this question

2 Answers 2

up vote 2 down vote accepted

It's part of ArcGIS (ArcGlobe) Default setting in the cache options:

you can switch it off...

alt text

& in 9.3

alt text

http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//00q800000069000000.htm

http://webhelp.esri.com/arcgiSDEsktop/9.3/index.cfm?TopicName=Caching_in_ArcGlobe

share|improve this answer
    
Mapperz - Thanks for replying, but I'm not using ArcGlobe. It is installed on the machine, but I don't think anyone is using it. The ArcGISCacheMgr.exe is running under the ArcSOC user account, so I think it has something to do with arcgis server. –  Kirk Kuykendall Dec 6 '10 at 14:26
    
On a machine with no ags running I have arcgiscachemgr.exe running. I turned off and Walla! no more cachemgr. Thanks mapperz BTW I had arcglobe installed but had never run it and cachemgr was still running. –  Brad Nesom Dec 6 '10 at 14:31
    
Kirk - If ArcGIS Server is running with the ArcGlobe Extension installed it will run regardless if not using it. –  Mapperz Dec 6 '10 at 16:05
    
I opened arcglobe, I think this is the first time it has ever been opened on this machine. All "do not use disk cache" boxes were unchecked on each of the layers (which I suppose are there by default). I checked each one of them, then saved to Untitled.3dd. After quitting I still see the ArcGISCacheMgr.exe running, so I killed it. After a few minutes it hasn't come back, will post back if it does reappear. Thanks! –  Kirk Kuykendall Dec 7 '10 at 23:06

10 has two new really obnoxious services.

Cachemanager and desktop indexing.

Cachemanager is not as annoying as indexing. My indexing pops up a LOT with a crash error. I can't yet find a way to turn it off. I remember telling it to turn on during installation (or maybe right after).

I shrugged and thought yeah that would be good to have my gis data indexed for quick searches. (have you seen the cool location searches you can do now?). But I am wearying of the problems with it.

Cachemanager I think you can get to in the ArcGIS program group (not at that pc now). I do know that you can see both of the processes in task manager.

I'll research and edit.

share|improve this answer
    
Brad - Thanks for looking into this. I think it has something to do with arcgis server. The ArcGISCacheMgr.exe process is running under the ArcSOC account. –  Kirk Kuykendall Dec 6 '10 at 14:27
    
On my AGS machine I do not have arcglobe installed and there is no arcgiscachemgr.exe running. I think Mapperz's solution is the right way to look. Let us know. Just read the 10 help file searched cache manager and turned on more "understanding cache management in arcglobe". –  Brad Nesom Dec 6 '10 at 14:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.