Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am having an issue with QGIS 1.8.0 on my Mac where I left click then right click which gets treated as a double click if the timing is too close together and brings up the Layer Properties box.

This usually happens when I am focused on a different program, left click to gain QGIS' focus and then right click to get a context menu for a layer. This is force of habit I guess.

  1. Is there a way to disable the Layer Properties from appearing with a double click? I know that you can choose between the Attribute Table and the Properties Box.

  2. Should this issue be added as a bug report to QGIS?

share|improve this question
add comment

3 Answers 3

up vote 2 down vote accepted

This has bothered me for a while, too! (I guess we have the same habits :^)

It also happened whenever the legend was out of focus while still in QGIS (like when editing in the canvas, then doing a quick left-right click in the legend). I have fixed this in master branch, but just for Mac since @underdark indicated it did not exhibit the same behavior under Linux.

Now on Mac, any quick left-right clicks on legend items shows the contextual menu for that item, as expected.

There will be no backporting of fixes in master branch to 1.8. If you wish to take advantage of the fix, try compiling QGIS yourself, or possibly try one of the nightly builds in a day or so.

In the future I suggest reporting any bugs to the issue tracker at hub.qgis.org for more direct communication with developers.

share|improve this answer
    
Thanks @dakcarto I will try one of the nightly builds in a few days. I will also use the issue tracker in the future. Thanks for the quick response. –  CDavis Nov 21 '12 at 19:57
add comment

You could add a feature request for adding another option to the double-click settings for "do nothing".

This behavior seems to be a specialty of your OS. I tried on Ubuntu and no matter how fast I click, there are no double-clicks registered when clicking left and right.

share|improve this answer
add comment

Seems to be a Mac-problem... I can reproduce the Problem on my MBA.

Is your double-click speed set on the highest setting? If not, try that. I had a way harder time opening the layer preferences with right then left clicking while it was set on the fastest setting.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.