Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

This was never a problem with ArcGIS 9 but it appears that in 10.0 Esri has added small horizontal lines as the default when including color ramps in legends. I want to get rid of these annoying lines, but I haven't figured out how to. Anyone else run into this problem?

share|improve this question
1  
A screenshot image would be very helpful. –  L_Holcombe Nov 21 '12 at 21:05
    
please upload a screenshot of your problem –  wetland Nov 21 '12 at 21:23
    
I can't upload a screenshot because StackExchange won't let me since I'm a new user (I got an error saying that my reputation score needs to be 10 or something). I'll do my best to describe it in words. Next to the color ramp in the legend there are three tiny horizontal lines - one at the top, one at the bottom and one in the middle all on the immediate right of the color ramp. If you've got Arc10 you'll see it pretty immediately. –  Tom Dilts Nov 21 '12 at 23:42
1  
Upload the image manually, for example to imgur.com and put the link to it in your question. Someone will come along and edit it to display the image. Alternatively you should now have enough reputation to try it again the usual way. –  blah238 Nov 22 '12 at 1:08
add comment

2 Answers

you can try this :

  1. right click in your legend

  2. click convert to graphics.then click Ungroup . continue this process(ungroup) for your color ramp . the ungroup option will be disable. enter image description here

  3. right click your color ramp .click properties

.enter image description here click change symbol . click edit symbol. in symbol property editor window , choose gradient fill symbol for type .enter image description here . you can change style, interval etc.

share|improve this answer
    
I think that wetland provided the best answer. Thanks! The key is to increase the number of intervals to a very high number and then increase the percentage to 100%. I'll make sure to post something on the Esri Ideas Forum. –  Tom Dilts Nov 26 '12 at 21:27
    
I've posted something on the ArcGIS Ideas page. Hopefully it will gain some traction. c.na9.visual.force.com/apex/ideaView?id=087E00000004QYDIA2 –  Tom Dilts Nov 26 '12 at 21:43
    
if the answer solve your problem . set this as your accepted answer –  wetland Nov 27 '12 at 6:42
    
Updated link to ArcGIS idea –  Luke Jul 26 '13 at 10:10
add comment

I think I see what you are talking about (see screenshot below), and no, I do not think there is any easy way to get rid of the tic marks along the color ramp.

Tic Marks

About the only two things you can do is use ArcObjects to set the color ramp symbol's ShowTics property to false (which I am not positive will do the trick but sounds plausible), or use the drawing toolbar to manually draw the legend or "cover up" the tic marks, with a white rectangle for instance.

Perhaps the best course of action would be to post this request on ArcGIS Ideas and get people to upvote it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.