Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Hi I am new to both android and qgis, but have 20 yrs experience with mapinfo and arc gis. I have installed qgis on a nexus 7 (4.2), but keep getting the error :

No qgis data provider plugins found in /data/app_lib/lib No vector layers can be loaded.

Any assistance in fixing this error much appreciated. Thanks

share|improve this question

3 Answers 3

This looks like it may well be able to solve your issue:

http://www.opengis.ch/2012/11/24/fixed-workaround-version/

UPDATE 03/02/13:

I'm now experiencing the same "No qgis data provider..." error when building from source (also on Nexus 7 [Android 4.2]).

I've pasted the output of logcat for both the installation and launching of QGIS on pastebin here.

I used the .apk found here:

http://android.qgis.org/download/apk/release/qgis-9-armeabi.apk

share|improve this answer

I know this should be a comment, but I've not enough reputation to comment on the question. Sorry.

Anyway, could you post:

  • the apk version you used
  • the logcat of the problem

You can see the logcat (android logs) by using the adb logcat command on your pc (if you have the android SDK) or directly on the device using the alogcat free application available in the market.

I've never seen that error.

share|improve this answer

guys, I'm working on this. This is due to the new folder structure from android 4.2. (see here) I'll release an update soon. keep an eye on my blog

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.