Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

enter image description hereI tried to extrude buildings in ArcScene with Extrusion function in Layer Properties. But most of the buildings seem like only their walls are extruded. Instead of solid blocks, they appear like no roof and ground.

Any one knows how to solve this problem? thanks so much!

share|improve this question
2  
Can you post the printscreen? Are you sure that your buildings are polygons? webhelp.esri.com/arcgisdesktop/9.3/… –  nadya Nov 23 '12 at 1:54
    
I've posted a screenshot to the original question. As you can see, most of the buildings are like only walls, only few of them are extruded as solid boxes. I have checked that they are polygons with Z values. Thanks for your help! –  user13036 Nov 23 '12 at 8:30
1  
Are all your houses polygons or are some of them line features? If they are all polygons, have you checked the validity of the geometry? –  MappaGnosis Nov 23 '12 at 9:11
    
Yes they are all polygons. How can I check the validity of the geometry? if they are not valid geometry, is there any way to repair them? –  user13036 Nov 23 '12 at 9:55
    
Thanks Sylvester Sneekly. It was the problem of geometry. I used Repair Geometry tool and now they are just pure solid blocks. –  user13036 Nov 25 '12 at 17:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.