Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have a problem with this Geoserver plugin. I have done the following:

  • downloaded the plugin from http://gridlock.opengeo.org/geoserver/2.2.x/community-latest/
  • extracted archive to /var/lib/tomcat6/webapps/geoserver/WEB-INF/lib/
  • restarted tomcat6 uncommented required line from /geoserver_data/security/authkeys.properties restarted tomcat6 again
  • and still I can access all WMS services without authkey in the URL

What am I doing wrong? I am probably forgetting something and can’t figure what. Please help? THX

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Sounds like you have not enabled security on GeoServer. You need to secure your instance of GeoServer with one or more user accounts and then you associate a range of authkeys with those users.

You will also need to set the WMS to "Hide" mode so that it does not broadcast its capabilities unless being accessed by a user or someone making a request using the authkey(s) you have setup.

share|improve this answer
    
thank you, it works now :) –  Mario Miler Feb 27 '13 at 22:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.