Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'd like to know if there are ways (within ArcGIS itself) to increase the display performance of basemaps within ArcMap. The internet connection was recently upgraded, so it is much faster than before, and by that I mean instead of taking 1 minute to draw the Bing Imagery basemap, it now takes about 30 seconds.

I normally pan and zoom with the basemap off, and once I think I'm in the location I want, I turn the basemap on and take my hands away from the mouse (trying to do anything else guarantees me a spinning circle, and most likely a crash). From this post on the ArcGIS forums, I've changed the location of my display cache from My Documents to my C drive, and I could see an improvement.

I then changed the location to our server, and it now takes about 5 seconds to draw when I pan and zoom. While I am quite happy with this, does the fact that I am using 10.1 make a difference? I changed the cache locations for my colleagues who are using 10.0, and their performance did not improve at all. I don't know what else to do, as I can't do anything about the antivirus/firewall part (that's under IT's control).

It's a bit frustrating, particularly when the basemaps in ESRI Maps For Office and ArcGIS for AutoCAD draw almost instantly, and I can zoom in without worrying my computer will implode. My current settings in ArcMap options are hardware acceleration enabled, and cache location changed.

I've looked at the help on managing your local display cache, but my settings appear to be optimised already, unless I am missing something.

share|improve this question
1  
Very good question. This has been an annoyance of mine for a long time and makes basemaps nearly unusable, even on university and business class connections. I doubt it's anything specifically about your configuration, but I have no pointers to fix it - just hope somebody knows. –  nicksan Dec 5 '12 at 23:19

1 Answer 1

This sounds like a conflict with your graphics card and the hardware acceleration setting in ArcGIS. I strongly recommend you turn off hardware acceleration and test. Good luck!

share|improve this answer
    
I have had hardware acceleration turned off for a few days, there is no difference. Also my drawing speeds have returned to what they were when my cache was stored in My Documents. I'm starting to think that this is an internal IT issue. –  Arabella Dec 1 '12 at 7:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.