Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I imported a track log in GPX format to QGIS. The track had two layers, the track points and the track, a smooth line joining the track points.

Why does the attribute table for the track points have no positional information in it? It has info I can understand in the hdop and vdop columns and also the one for ele(vation) but there is no column in the attribute table to hold positional data.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

You can use the Field Calculator's geometry option $X and $Y to create new columns that contain position data.

share|improve this answer
    
OK that worked mostly but I got some errors when I tried to save the edits to the attribute table. This is the way forward though, thank you. –  Nigel Law Dec 2 '12 at 19:10
    
You have to export the track_points layer to another format, like shapefile. That format can be edited. Loading GPX with Add Vector layer is just import, unless you use Vector->GPS-> GPS tools. But that won't give you track points. –  Andre Joost Dec 3 '12 at 9:51

In GIS world, the geometry is stored compressed in a (hidden) separate table, which is not human readable. Editing geometry and attribute values are managed seperately.

Thats different to the GPX format, where you can read every information. But that would make working with the data very slow, when it comes to gigabytes of data.

If you export to GPX, the two worlds will be combined again.

share|improve this answer
    
Thanks Andre. If I open the gpx file in a text app I can see the data. Interestingly the only 'attributes' shown there are lat, lon, ele, time hdop, vdop. Thats five. The attribute table that QGIS seems to construct on importing the GPX file has 20 attribute columns most of them with NUL content. the two lat and lon columns only hold 9 digit floating point data but those two columns have been 'compressed' somewhere out of sight and replaced with 14 columns of NULL data I can see. Seems a bit strange! –  Nigel Law Dec 2 '12 at 18:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.