Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have joined two tables (excel 10 but saved as 03 to import it into ArcGIS) in ArcGIS 10 based on a column. This column has some empty records in both tables. I need the agreeing records to be added to the right and the others to be on the bottom of the table. After fiddling with it I got it to work; we filled in the empty cells of that column with dummy numbers. Anyway, the problem now is that when I export the joined table, the second (right) half of it is empty (all zeroes) even though the joined table was just fine. I tried exporting it as dbf and txt and neither worked.

Does anybody have an idea how to fix this? Thanks a bunch!

share|improve this question
    
Would you be able to include some tables indicating what their data look like and what you are expecting in the output, please? No need for too many rows or columns in each. Also, perhaps you can list and number your steps so that we can more easily follow what you have tried to do so far. –  PolyGeo Dec 5 '12 at 23:54
1  
@Julie, are your xls columns in the dbf less than 11 characters and do not contain any weird characters that dbf do not like? I would suggest to try the join against a geodatabase feature class then export to geodatabase features class to see if you get the same result or not. –  artwork21 Dec 6 '12 at 1:30
add comment

migrated from meta.gis.stackexchange.com Dec 5 '12 at 17:54

This question came from our discussion, support, and feature requests site for cartographers, geographers and GIS professionals.

1 Answer

Perhaps try sub-setting the two tables to just the records that have values, and then do the join. Have you tried the Join Field tool?

If the problem truly does lie with the Excel format then here are some suggestions. Excel tables plague me in ArcGIS so I typically export them as CSV, convert to GDB or DBF in ArcGIS, and then perform the join after they appear correct and intact. Below are some guidelines (which you know most already) for using Excel directly:

  1. ArcGIS can only read Excel version 2003 or earlier (no .xlsx files)
  2. Only one worksheet can be imported at a time
  3. Column headings (field names) must be present and typically 10 or less characters
  4. Do not use spaces or non-alphanumeric characters in column headings (invisible spaces after the column name will cause the entire table to not import in to ArcGIS)
  5. No skipped rows anywhere
  6. Be aware that date/time values are subject to import errors (a work around is to split the date/time parts in to separate columns)
  7. Add dummy values to the first row of data so that ArcGIS knows the data type (and number of characters if necessary) that column should have (delete this row after successfully bringing in to ArcGIS)
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.