Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm wondering if there is any method to preserve the original field names in Arc GIS when I join csv. tables to a Shapefile.

I ask, because sometimes I join tables with 10, 20 or even more columns and when exporting the joined data Arc GIS always renames them according to the name of the original table and the order of the column (e.g. table_xy_1,table_xy_2, etc.).

Since there is no easy way to rename the fields in the attribute table permanently (i.e. you have to create a new column and copy the old on into this new column AND delete the old column) this creates a bunch of work (despite from the fact that you have to orientate yourself in this mess of field names)

So I can't actually believe that there is no more efficient way to do such a basic operation in Arc GIS...

share|improve this question
1  
Could you put in a screenshot of what is happening? When I add a csv, it takes the first line as the field names and displays them when you open the table. What it sounds like is you either don't have valid names in your csv or you have duplicates field names between the original and the join table. Regardless, a graphic would help more clearly illustrate your problem. –  Get Spatial Dec 6 '12 at 17:30
    
hey. this problem only occurs when you export the data to a new shapefile. Within the old one it is still okay. I edited the question so that it is fully understandable –  Dspanes Dec 10 '12 at 10:31

2 Answers 2

up vote 10 down vote accepted

I think what you might be trying to do is NOT use "fully qualified table names".

To do so, in Environment Settings -> General Setting, uncheck "Maintain fully qualified name".

Take a look at this Esri support forum and this online help article.

share|improve this answer
    
thanks for your advive Ryan. i just checked the recommended information and in theory this should solve my problem yes. So I uncheked this option in ArcGIS and also saved this option uncheckd as default. But for some reason when I export my data it just won't work. ArcGIS still exports the data as: tableName.fieldName. In my case the output is something like this Rural_I_1, Rural_I_2, Rural_I_3 and so on...This may be a bug since I'm using ArcGIS 10.1...I dont know. A Workaround is to give the table a very short name like "1" so the outpust is "1_csv_su" and I know that su stands for sugercane –  Dspanes Dec 10 '12 at 10:54
    
I think it al comes down to the basic problems of working with the shapefile format in ArcGIS. Some of this limitations envolve for example the 10 number limits for fieldnames (see gis.stackexchange.com/questions/15784/…) or the inability to export the field aliases (ideas.arcgis.com/ideaView?id=087300000008DwdAAE). It brings me down to the conclusion that it may better to work on tables outside of ArcGIS. –  Dspanes Dec 10 '12 at 11:07
1  
@Johannes, Before working on your data outside of ArcGIS, why not try converting your data to a more modern database format that ArcGIS supports like a file geodatabsae, or even a personal geodatabase. At least then you would know that it is a shapefile limitation, and not an Arc limitation/Issue/Bug. –  RyanDalton Dec 10 '12 at 15:57

I solved this problem for a particular case. I had joined a .csv file to a .shp file and exported the data. I was getting the Rural_I_1 problem described above ... it was appending the file name of the .csv to the field names.

My work around was to first export the .csv file as a .dbf table (from arcgis). Then do the join on the .dbf rather than the .csv. When you export the data now, you will just get the original field names, without the file name appended.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.