Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am having trouble with a new shape layer not showing up on my map. The attribute table is showing up fine and all of the points are in there, however visually, there are no dots showing on the map. I have made sure that the new shape layer was at the very top of the stack. I tried placing the new shape layer on a blank new project and it worked perfectly as it should. Then I re-opened the original problem project, deleted all of the existing layers, saved it as temp with no data in it at all, and then closed and re-opened the project and re-loaded the problem shape layer into the new temp project. It did not show up again.

I have gone back to my original data and re-created the csv that I initially used to create the shape file (did this a couple of times), in case there was some spurious content in there, however, this had no effect, and the problem remains.

Using QGIS 1.8.0 and Windows 7 64-bit. However I installed QGIS onto a Linux machine and the identical problem occurred.

Hope someone can help, or has an idea what it might be...

share|improve this question
1  
If you can share the shapefile, others can investigate. Most probably the layer CRS is set to EPSG:4326 (latlon degrees), showing no results if the data contains projected coordinates. –  AndreJ Dec 11 '12 at 5:17

2 Answers 2

up vote 7 down vote accepted

if you got error in both OS and you can see the information on attribute table, maybe there is a problem with the Coordinate Reference System (CRS).

  • First, when you created the shapefile through "Add Delimited Text Layer" tool, did you assign the CRS?;
  • Second, when you create the project, are you sure that all layers are in the same CRS; If do not, did you activated the option "Enable on the fly CRS tranformation" on the Project Properties window?

CRS tab

share|improve this answer
    
Thank you! I checked the CRS of the existing layers and made sure the new one matched. I had set it as GDA94 instead of GDA94 / MGA zone 55 (which is what the rest of the layers were set to ... I am in Tasmania Australia). Now it works! –  Maria Dec 11 '12 at 22:09
    
I am glad I could help you :) –  gtapko Dec 12 '12 at 1:02

Right click on the layer, Zoom to layer. Once you are there, are the coordinates realistic?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.