Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My UTM shapefile lines up with Google layers if the project CRS is set to WGS84 mercator projection (including default 3857 and Google). But if I set the project CRS to UTM Zone11, they are slightly shifted. I've tried loading them and setting the project CRS in various orders - nothing worked.

share|improve this question
up vote 5 down vote accepted

You have to set your project CRS to EPSG:3857, if you want to use Google layers in the QGIS Openlayers plugin. Everything else does not make sense, because reprojection of 256x256 tiles does look ugly (unless you stitch them together and reproject the hole picture, but openlayers does not do that).

share|improve this answer
Thanks. New to QGIS and just learning the ropes. I suppose the only way to display in UTM is to save the background within my extent as a georeferenced image and then reproject it. I don't suppose there is an easier way than exporting the image and then setting control points (i.e. automatically write world file)? – Allison Dec 11 '12 at 16:16
You can use File->Save as image, then delete the Google layer, change the project CRS to WGS84 UTM of your part of the world, add the saved picture with Layer->Add raster layer. You will be asked for the layer CRS, choose EPSG:3857. But the result looks a bit washed-out, because the saved image only has screen resolution. Perhaps its better to zoom in and make several screen copies. – AndreJ Dec 11 '12 at 19:58

I digitise from the Google background whilst the the CRS is in the Google Mercator projection 900...

Openlayers is a plugin to QGIS, so not directly supported by the dev team. There have been less problems in the map canvas and more reports of issues in the print composer. You may find the next version of QGIS deals with the apparent problem.

See these

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.