Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have few data in which ArcGIS Java Script version 2.6 and 2.8 is used & I am upgrading it to ver.3.0/3.1 and getting different errors like (Store error,Map display is blank etc.)

I searched on Google and ArcGIS Forum also following this article still getting an errors also I refereed few posts in which its mention that update the "store" but where should I exactly update ??

If anyone knows then please let me know.. thanks in advance : )

share|improve this question
add comment

1 Answer 1

up vote 3 down vote accepted

in order to help solve your problems, we'd need to know what specific errors you are getting.

There are some minor changes from 2.x to 3.x versions of the JavaScript API, but by and large you can get away with using most of the same code.

The major changes I apply when converting from 2.x to a 3.x site are to update the dojo config module (as explained in the link you reference in your post).

Also, if upgrading to version 3.2, you need to include a reference to esri.css as mentioned in this page: What's new in 3.2

share|improve this answer
    
thanks for your reply..I will check this and let you know.. –  Sunil Dec 14 '12 at 6:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.