Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've installed QGIS Server as the guide you posted here and when I finished and tried doing http://localhost:83/qgis/qgis_mapserv.fcgi.exe?SERVICE=WMS&VERSION=1.3.0&REQUEST=GetCapabilities I get error :

Internal Server Error    
The server encountered an internal error or misconfiguration and was unable to complete your request.    
Please contact the server administrator, admin@local.domain and inform them of the time the error occurred, and anything you might have done that may have caused the error.    
More information about this error may be available in the server error log

The log shows :

 [Wed Dec 12 22:25:19 2012] [notice] Apache/2.2.14 (Win32) mod_fcgid/2.3.6 configured  resuming normal operations
[Wed Dec 12 22:25:19 2012] [notice] Server built: Sep 28 2009 22:41:08
[Wed Dec 12 22:25:20 2012] [notice] Parent: Created child process 3868
[Wed Dec 12 22:25:20 2012] [notice] Child 3868: Child process is running
[Wed Dec 12 22:25:20 2012] [notice] Child 3868: Acquired the start mutex.
[Wed Dec 12 22:25:20 2012] [notice] Child 3868: Starting 64 worker threads.
[Wed Dec 12 22:25:21 2012] [notice] Child 3868: Starting thread to listen on port 83.
[Wed Dec 12 22:26:08 2012] [warn] [client] (OS 109)The pipe has been ended.  : mod_fcgid: get overlap result error
[Wed Dec 12 22:26:08 2012] [error] [client] Premature end of script headers: qgis_mapserv.fcgi.exe
[Wed Dec 12 22:26:09 2012] [error] [client] File does not exist: C:/OSGeo4W/apache/htdocs/favicon.ico

And I couldn't find solution in other questions here.

What could be the problem ?


share|improve this question
Have you checked the wiki page for potential pointers:… – underdark Jan 25 '13 at 18:50
i m having the same problem. Where can i get that missing files? I couldnt find it anywhere – Vaibhav Mistry Oct 23 '13 at 13:26
@VaibhavMistry I don't remmember where from , It was 10 months ago. I do recall it was a site I could search for DLLs and download it from there. – Alophind Oct 23 '13 at 14:56
up vote 3 down vote accepted

I've found out when double clicked "qgis_mapserv.fcgi.exe" that libfcgi.dll was missing. problem solved.

share|improve this answer
Hi Alophind, I was getting the same error except QtXML4.dll was missing so I added C:\OSGeo4W\bin to Path which solved that but now I am getting libfcgi.dll is missing, how did you fix this? – Matt Nov 12 '13 at 9:37
Hi Matt , I assume you need to add this dll and register it with windows (never had this error , but just guessing). Best of luck ! – Alophind Nov 12 '13 at 18:43

I had the same error log in Apache except for the last row.. I ran the qgis_mapserv.fcgi.exe in cmd and found out that the program missed python modules:

ImportError: No module named site

I simply copied all modules + the folder named encoding FROM C:\OSGeo4W\apps\Python27\Lib TO C:\OSGeo4W\apps\qgis\bin

share|improve this answer

I simply copied all modules + the folder named encoding FROM C:\OSGeo4W\apps\Python27\Lib TO C:\OSGeo4W\apps\qgis\bin

This worked for me after long search !!

share|improve this answer

adding the lines

SetEnv PYTHONHOME "C:\OSGeo4W\apps\Python27"
SetEnv PYTHONPATH "C:\OSGeo4W\apps\qgis\python"

to the configuration file


solved the python issue for me (Win 2008 R2)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.