Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm trying to insert new polygons that the user has drawn through the addFeatures REST endpoint and I'm getting an error when the user draws a bow-tie and tries to insert it. Is this simply not supported or am I missing some geoprocessing step?

share|improve this question
    
A little help please? Post points list going to the server. Please post error returned by the server and error code –  user13395 Dec 20 '12 at 2:38
3  
Did you try passing it to the simplify method on the geometry service first? –  Kirk Kuykendall Dec 20 '12 at 3:26
    
+1 for Kirks comments. This is one of our test cases and it works. If Kirk doesnt put together an answer by new year, ill put an answer down with some evidence. –  Simon Dec 22 '12 at 5:25
    
Sending the graphic to the simplify method is how I'm getting multiple rings. On the client after it is drawn, I have one ring that just happens to cross itself. The Silverlight Map control handles this fine. For now my solution is to just tell the user not to let the polygon edges cross. –  jrockers Dec 26 '12 at 23:27
    
Geometries are being stored in a SQL Server 2008 Geometry datatype. –  jrockers Dec 26 '12 at 23:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.