Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am trying to import a vector layer into GRASS, but I keep receiving the same error. The values in the vector layer are important because I would like to use them to create a heatmap. What could I be doing wrong?

Yesterday I managed to import the layer into GRASS, but it had discarded all the values.

The error message received when trying to import a vector layer into GRASS

share|improve this question
    
Perhaps there is some error with QGIS? I know that there are some features that I have problems with in GRASS since installing certain plugins. Uninstalling and reinstalling QGIS did not help, but I did manage to repair some of the damage by manually replacing missing files. Is there another way to 'repair' QGIS? –  Bernie Dec 20 '12 at 7:13
    
have you tried running <code>v.in.ogr</code> in GRASS? –  dmci Dec 20 '12 at 7:43
    
Tried this method, it just results in an error as well. –  Bernie Dec 20 '12 at 8:02
    
Have you checked the layer's geometry validity? I had the same trouble recently and that did the trick for me. –  GR_ Dec 20 '12 at 12:11
    
Sorry, still rather new to all of this. How do I check the layer's geometry validity? –  Bernie Dec 20 '12 at 12:15
show 6 more comments

1 Answer

up vote 0 down vote accepted

After many fruitless attempts, I finally changed the columns around in the spreadsheet and voila! It worked. Thanks for all the help offered.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.