Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How do I repair the following problem:

NVIZ error

The error occurred while I was trying to run NVIZ in the GRASS environment in QGIS. NVIZ however runs perfectly in GRASS. On checking the directories listed, init.tcl is located there.

share|improve this question
Not sure if you are using the latest version of QGIS, but.. did you tried already to uninstall and install it again (with the last version of QGIS)? Do you have Windows 64bit ?? – A.R Dec 27 '12 at 19:00
I am using the latest version of QGIS and have tried to uninstall and reinstall, but it doesn't work (seems to keep everything in memory and I'm not sure how to clear that). I'm using Windows 64bit. – Bernie Dec 28 '12 at 7:47

Please reinstall the Tcl/TK and the Python packages from OSGeo4W. It will solve the dependency problem.

share|improve this answer
Thanks! How do I do that exactly? I'm rather a newbie at this... – Bernie Feb 9 '13 at 13:53
I think (while not having Windows myself) that you launch the OSGeo4W wizard and then select the packages in question for re-installation (there should be a checkbox toggle to do so, it is rather intuitive). Probably they are available within the "advanced" stuff section. – markusN Feb 10 '13 at 9:29

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.