Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

The GRASS 6.4.3Svn for Windows that i have in my machine does not have GDAL/OGR support. Is there any library (libgrass) for Windows to add into existing GRASS installation. If not, how to build or install GRASS with OSGEO4W installer including GDAL/OGR support?

share|improve this question
1  
Here's a similar question: gis.stackexchange.com/a/2279/4119. Did the OSGeo4W installer not work for you? If not, what when wrong? –  katahdin Dec 23 '12 at 13:07
2  
@katahdin - the question is not about installing GDAL/OGR with Python, but GDAL/OGR with Grass vector support which is not compiled in to GDAL/OGR by default and it doesn't look like it's included in OSGeo4W. –  Luke Dec 23 '12 at 20:27
1  
@Sanjeewa - I haven't edited your question in case I have misinterpreted your meaning, but I assume based on your previous question that you mean: The version of GDAL/OGR for Windows that I have installed does not have GRASS vector support. Is there a GRASS driver plugin for Windows to add to an existing GDAL/OGR installation. If not, how to build or install GDAL/OGR from OSGEO4W including GRASS support? –  Luke Dec 23 '12 at 20:34
1  
@katahdin - the question is not about installing GRASS which is available in OSGeo4W, but Grass vector support for GDAL/OGR. As per gdal.org/ogr/ogr_formats.html Grass vector support is not compiled in to GDAL/OGR by default and it doesn't look like it's included in OSGeo4W. –  Luke Dec 23 '12 at 22:39
2  
When you install GRASS from OSGeo4W you should certainly have GDAL/OGR support. What did you try in GRASS that makes you think GDAL/OGR is not available? Did you test first with the stable 6.4.3RC3 ?? –  Micha Dec 24 '12 at 14:30

2 Answers 2

I installed GRASS through OSGEO4W installer and found that GRASS vector support for GDAL/OGR is not included in the current OSGEO4W. Required to inform GRASS developer list about this.

share|improve this answer
    
This is incorrect. You need to select the correct packages. –  markusN Dec 28 '12 at 19:23
    
In OSGEO4W installer, i cannot see gdal_grass package under libs –  Sanjeewa Dec 29 '12 at 6:05
    
There is gdal_grass plugin under obsolete category. However it does not work with the stable GRASS release 6.4.x in OSGEO4W. –  Sanjeewa Dec 31 '12 at 14:21
1  
@markus If you have been able to install gdal_grass with other relevant packages, please inform of versions of such packages for the benefit of the others. I tried both gdal1.5_grass and gdal_1.6_grass plugins with GRASS 6.4.x stable release in OSGEO4W.But both did not provide gdal/ogr support within GRASS. –  Sanjeewa Dec 31 '12 at 14:28

You need the GDAL-GRASS plugin to be additionally installed.

For OSGeo4W, see the package info at

http://download.osgeo.org/osgeo4w/release/grass/gdal-grass/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.