Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have a fairly extensive workspace which among other things has an output of shapefiles in several needed projections.
I have those going to the respective folders for use in different business needs.

There seem to be several problems with one of my processes (I am using the clipper to split datasets by county lines.)

First the configuration of my clipper is with the counties (polygon)[esri geodatabase sqlserver] as the clipper and the dataset (polygon)[esri goedatabase sqlserver] as the clippee. The clippee has several polygons (20) that overlay several counties.
Several of those would "cut" a clippee polygon.
clipper1
I have tried several scenarios within the parameters dialog (including single clipper, multiple clippers, and clippers first); but first don't see a change in the results and, second don't see what I want.

The results are that

  1. some of the data is passed through the "inside" port of the transformer, but is not clipped by the boundaries in the clipper dataset.
  2. the attributes I want to use to fanout my dataset on are not in the data.
  3. All of the data is passed through the "outside" port but is again not clipped, and has no attributes from the clipper dataset.

What I ultimately want is a separate dataset for each county with each respective clippee element having the attributes of the county that clipped them, and a few of their own attributes from the original data.
Edit:
I am confused. I created a new workspace with only my clipper and one clippee.
I do get results in my inspector view but all values show clipped - no. I have done as you said the clipper is on top and the multiple clippers is chosen.
I still can't make the 2 attributes from the clipper turn "green" but they are in the output (blank values).
HMM! Not sure what I am doing wrong at this point.

I see these values in the log. REJECTING BELOW FEATURE: Error - Expected an aggregate or area geometry. REJECTING BELOW FEATURE: Polygon feature must have at least 4 coordinates...rejecting REJECTING BELOW FEATURE: Error - Expected an aggregate or area geometry. REJECTING BELOW FEATURE: Polygon feature must have at least 4 coordinates...rejecting
Apperantly clipper doesn't take line features as clippee. I added a bufferer (because of the confusing message) and not It is creating 3300 fan out datasets.
Now I have to figure out how to make it just create a dataset for clippers that have clippees in them.

share|improve this question
    
Is your source data from a file (shape,dxf) or from a database (oracle, postgis)? –  Mapperz Dec 28 '12 at 18:09
    
@mapperz sqlserver esri geodatabase sde schema –  Brad Nesom Dec 28 '12 at 18:50

1 Answer 1

up vote 2 down vote accepted

I think the key is setting your data to be read in the correct order.

Flat files can be controlled better (more easily) than the way they are stored in a database.

single clipper, multiple clippers, and clippers first are more geared to performance handling

The 'Clippers First' setting (under Clipper Type) tells FME that the flow of data is A) all Clipper features, then B) all Clippee features. The Clipper reads features one at a time as before, but as soon as a Clippee feature is encountered, can assume that the set of Clippers is exhausted. Now Clippee features can be processed one at a time without having to hold the entire group in memory. The only features stored in memory are the Clippers - and there are generally fewer of those.

So how does a user ensure that all Clipper features are first? There are three ways:

Clippers and Clippees are normally held in separate datasets. FME reads all datasets in the order shown in the navigation pane; top dataset first. Therefore, by moving the Clipper dataset to the top of the list, (right-click it and choose the option to 'move up in list') a user can force those features to be read first. If the Clippers are held in the same stream of data (but obviously split up before entering the Clipper), then the Sorter transformer can be used to promote the Clipper features in front of the Clippees. The FeatureHolder transformer put before features enter the Clippee port is an alternative for the Sorter.

When used this way, the Clipper becomes a successful alternative to the PointOnAreaOverlayer.

This is the source and guide for the clipper transformer and it's options:

http://fmepedia.safe.com/articles/Samples_and_Demos/Example-of-Using-the-Clipper-Transformer

share|improve this answer
    
I still haven't gotten it to work right. But I htink you convinced me tha tI am not doing anything specifically wrong. It just doesn't work like the intersect command in arcgis! –  Brad Nesom Dec 28 '12 at 21:33
1  
I easily get the clipper and clippee the wrong way around - an easy mistake - sometimes the intersector works better - or get the SQL Executor/Creator out and get the DB to do the work. –  Mapperz Dec 28 '12 at 21:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.